Oplossing: er is een verificatiefout opgetreden, de gevraagde functie wordt niet ondersteund

Sommige gebruikers krijgen de  foutmelding Er is een verificatiefout opgetreden, de gevraagde functie wordt niet ondersteund , wanneer ze proberen de verbinding met extern bureaublad  tussen twee Windows-computers te gebruiken. De meeste getroffen gebruikers melden dat het probleem pas begon te verschijnen nadat een Windows-update was uitgevoerd.

Wat de verificatiefout veroorzaakt, is opgetreden. Gevraagde functie wordt niet ondersteund fout?

We hebben dit specifieke probleem onderzocht door verschillende gebruikersrapporten te bekijken. Op basis van wat we hebben verzameld, zijn er verschillende scenario's die dit specifieke foutbericht activeren.

  • Fout wordt veroorzaakt door een Windows-update - De kans is groot dat de fout wordt veroorzaakt door een Windows-update die halverwege 2018 is uitgebracht. De oplossing dwingt de Remote Desktop-verbindingsapp om ervoor te zorgen dat beide betrokken werkstations het CredSPP van maart 2018 gebruiken patch. Door beide computers bij te werken met de nieuwste updates, bent u er zeker van dat ze klaar zijn voor een Remote Desktop-verbinding.
  • Het Oracle-herstelbeleid voor versleuteling is uitgeschakeld - Sommige getroffen gebruikers hebben ontdekt dat in hun geval de verantwoordelijke schuldige een uitgeschakeld lokaal groepsbeleid was. Als de versie van uw besturingssysteem dit toestaat, kunt u de fout waarschijnlijk omzeilen door het Oracle-herstelbeleid voor versleuteling in te schakelen.
  • AllowEncryptionOracle is ingesteld op 2 - Er is een bepaalde registersleutel ( AllowEncryptionOracle ) waarvan bekend is dat deze dit specifieke foutbericht activeert, tenzij deze is ingeschakeld. Verschillende gebruikers die hetzelfde probleem tegenkwamen, hebben gemeld dat het probleem is verwijderd zodra de registersleutel is gewijzigd.

Als u dit foutbericht niet kunt oplossen, vindt u in dit artikel een verzameling geverifieerde stappen voor probleemoplossing. Hieronder vindt u een verzameling methoden die andere gebruikers in een vergelijkbare situatie hebben gebruikt om de  foutmelding Er is een verificatiefout opgetreden en de gevraagde functie wordt niet ondersteund .

Alle onderstaande methoden zouden u moeten helpen het probleem op te lossen, dus volg de methode die het meest van toepassing lijkt op uw scenario.

Methode 1: Windows bijwerken met de nieuwste beveiligingspatches

Om de Remote Desktop Connection te laten werken, moeten beide betrokken werkstations worden gepatcht met de CredSSP-patch. In mei 2018 heeft Microsoft een patch uitgebracht die elke betrokken machine dwingt om de CredSPP-patch te gebruiken. Als een van de betrokken computers de beveiligingsupdate niet heeft, krijgt u de  foutmelding Een verificatiefout opgetreden, de gevraagde functie wordt niet ondersteund .

U kunt er echter voor zorgen dat dit niet het geval is door ervoor te zorgen dat beide machines zijn bijgewerkt met de nieuwste beveiligingspatches. Hier is een korte handleiding om dit te doen:

  1. Druk op de Windows-toets + R om een ​​dialoogvenster Uitvoeren te openen. Typ vervolgens " ms-instellingen: windowsupdate " en druk op Enter om het tabblad Windows Update van de app Instellingen te openen.

    Opmerking: als u Windows 7 of ouder heeft, gebruikt u in plaats daarvan de opdracht " wuapp ".

  2. Zodra u bij het Windows Update-scherm komt, klikt u op Controleren op updates en volgt u de aanwijzingen op het scherm om elke in behandeling zijnde update (inclusief beveiligingsupdates) te installeren. Denk eraan om dit op beide betrokken werkstations te doen.
  3. Zodra beide computers up-to-date zijn, start u beide opnieuw op en kijkt u of het probleem is opgelost. Als u nog steeds de  foutmelding Er is een verificatiefout opgetreden, de gevraagde functie wordt niet ondersteund , gaat u verder met de volgende methode hieronder.

Methode 2: de Editor voor lokaal groepsbeleid gebruiken

Verschillende gebruikers die de  foutmelding Er is een verificatiefout opgetreden en de gevraagde functie wordt niet ondersteund,  hebben het probleem kunnen oplossen door de Groepsbeleid-editor te gebruiken om het Oracle-herstelbeleid voor versleuteling te wijzigen .

Opmerking: deze methode wordt niet standaard toegepast als u een Home-versie van Windows 7, Windows 8.1 of Windows 10 gebruikt. In Home-versies is de Local Group Policy Editor niet standaard geïnstalleerd, dus u kunt niet om de onderstaande stappen te voltooien. Maar u kunt dit probleem omzeilen door deze handleiding ( hier ) te volgen om de Editor voor lokaal groepsbeleid op Windows 10 Home-editie te installeren.

Zodra u zeker weet dat de Editor voor lokaal groepsbeleid op uw computer is geïnstalleerd, volgt u de onderstaande stappen om het Oracle-herstelbeleid voor versleuteling in te schakelen:

  1. Druk op Windows-toets + R om een ​​opdracht Uitvoeren te openen. Typ vervolgens " gpedit.msc " en druk op Enter om de Editor voor lokaal groepsbeleid te openen .
  2. Gebruik in de Editor voor lokaal groepsbeleid het linkerdeelvenster om naar Computerconfiguratie> Beheersjablonen> Systeem> Delegatie van inloggegevens te navigeren . Ga vervolgens naar het rechterdeelvenster en dubbelklik op Encryption Oracle Remediation .
  3. Stel het keuzerondje in op Ingeschakeld terwijl het beleid voor versleuteling van Oracle-herstel is geopend . Blader vervolgens naar beneden naar Beveiligingsniveau en verander dit in Kwetsbaar.
  4. Sla de wijzigingen op, sluit de Editor voor lokaal groepsbeleid en start uw computer opnieuw op. Kijk bij de volgende keer opstarten of het probleem is opgelost.

Als u de fout nog steeds tegenkomt of als deze methode niet van toepassing was op uw Windows-versie, gaat u naar de volgende methode hieronder.

Methode 3: Register-editor gebruiken

Als methode 2 niet van toepassing was of als u op zoek bent naar een aanpak waarbij de Editor voor lokaal groepsbeleid niet is betrokken , kunt u ook proberen het probleem op te lossen via de Register-editor. Sommige gebruikers die hetzelfde probleem proberen op te lossen, hebben gemeld dat het probleem is opgelost nadat ze de parameter AllowEncryptionOracle hebben gewijzigd . Dit is het equivalent van het inschakelen van het  Oracle-herstelbeleid voor versleuteling .

Hier is een korte handleiding over het gebruik van de Register-editor om de AllowEncryptionOracle  aan te passen  om de  foutmelding Er is een verificatiefout opgetreden, de gevraagde functie wordt niet ondersteund:

  1. Druk op de Windows-toets + R om een ​​dialoogvenster Uitvoeren te openen. Typ vervolgens " regedit " en druk op Enter om de Register-editor te openen.
  2. Navigeer in de Register-editor naar de volgende registersleutel met behulp van het linkerdeelvenster:

    HKLM \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ System \ CredSSP \ Parameters

  3. Ga naar het rechterdeelvenster en dubbelklik op AllowEncryptionOracle .
  4. Dubbelklik op AllowEncryptionOracle van het rechtervenster en zet het de Value data naar 2.  Hit Ok om de wijzigingen op te slaan.
  5. Sluit de Register-editor en start uw computer opnieuw op. Bij de volgende keer opstarten, zou u niet langer de verificatiefout moeten tegenkomen, de  gevraagde functie wordt niet ondersteund.